Disable Echo Channel via App

feature
completed

#1

It would be nice if we could disable the Echo channel via the app. Assuming more channels are coming soon, this will help get through channels quicker.


#2

I feel like this functionality must be coming when the ability to add more channels is released. More channels means the app will have to be able to configure channels and manage which channels each relay can access.


#3

That would be great, just wanted to suggest it anyway.


#4

I agree, we don’t use and likely won’t use the echo channel. Would love to be able to disable/remove it.


#5

I’m just guessing, but I think the main reason it is there is as a troubleshooting tool. It is the only way to use the device to confirm a wireless connection.


#6

What do mean by that? Simply trying to transmit a message, even the briefest, tells you if you have a connection.


#7

If you have no one to talk to (i.e. no other Relay on the account, app not yet working to communicate), then you can try to transmit a message, but no one to hear it or confirm it was sent. And sending a message does not confirm you can receive one.

I believe the echo channel sends the message to Republic Wireless’ Relay infrastructure, which modifies the message and sends it back, confirming successful 2-way communications are working.


#8

The tone that is heard after sending a message indicates whether or not you have a successful connection to the server. As that connection controls both in and outbound audio, I believe it should provided the needed feedback.


#9

Except, as Dan said, if you have no one in your group, the Relay immediately responds (when on the main channel) with “No one in your group is online” (or whatever it says). The echo channel works without anyone else in your group.

I still think this idea has merits, as a general way to disable any channel and it will keep my vote for now.


#10

If you only have one relay on your account, it gives a tone unless you’re not connected. Then it says, “[device name] is not connected to the Relay server.”

That doesn’t change the argument.


#11

I thought the ‘bad’ tone meant the message could not be delivered, for a multiple of reasons, including no connection to any network, leaving it un certain as to whether it was that Relay’s connection or something else, like no one available to talk to. If that is the case, then the echo channel provides surety that there is a connection.


#12

Thanks for that clarification. I get the potential usefulness now. I’d still love the option to disable.


#13